aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tempora/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tempora/APKBUILD')
-rw-r--r--community/py3-tempora/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/py3-tempora/APKBUILD b/community/py3-tempora/APKBUILD
index 77202f357f3..12b6e7cb241 100644
--- a/community/py3-tempora/APKBUILD
+++ b/community/py3-tempora/APKBUILD
@@ -1,39 +1,41 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-tempora
-pkgver=4.1.1
-pkgrel=0
+pkgver=5.5.1
+pkgrel=1
pkgdesc="Objects and routines pertaining to date and time (tempora)"
url="https://github.com/jaraco/tempora"
arch="noarch"
license="MIT"
depends="
- py3-jaraco-functools
+ py3-jaraco.functools
py3-tz
- python3
"
makedepends="
- py3-freezegun
- py3-setuptools
+ py3-gpep517
py3-setuptools_scm
- py3-toml
+ py3-wheel
"
-checkdepends="py3-pytest"
+checkdepends="py3-pytest py3-freezegun py3-pytest-freezegun"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/t/tempora/tempora-$pkgver.tar.gz"
builddir="$srcdir/tempora-$pkgver"
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver"
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest -k "not get_nearest_year_for_day"
+ pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/tempora-$pkgver-py3-none-any.whl
}
sha512sums="
-a272980be5d4448bbd97d9e48d8a992c07cd1e970924f301fd3444834fe112453d5714ff8f3e7af6a5775d931b825601d7f1abf3cd9319b08d148a2a07d40d07 tempora-4.1.1.tar.gz
+642c4176ea14504e2f831f738e1064c1fb888ad89a67c74d5bcf2a5389923af3933981393855c7eceaf6c7fc16bbbf4126015d2d1dfa0fdfd38d528d16854dce tempora-5.5.1.tar.gz
"