aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-termcolor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-termcolor/APKBUILD')
-rw-r--r--community/py3-termcolor/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/py3-termcolor/APKBUILD b/community/py3-termcolor/APKBUILD
index 0f44beda32f..600dc4b78a3 100644
--- a/community/py3-termcolor/APKBUILD
+++ b/community/py3-termcolor/APKBUILD
@@ -2,25 +2,33 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-termcolor
_pkgname=termcolor
-pkgver=1.1.0
-pkgrel=6
+pkgver=2.4.0
+pkgrel=1
pkgdesc="ANSII Color formatting for output in terminal."
url="https://pypi.org/project/termcolor/"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-installer py3-hatchling py3-hatch-vcs"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+options="!check"
replaces="py-termcolor" # Backwards compatibility
provides="py-termcolor=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --root="$pkgdir" --optimize=1
+ python3 -m installer -d "$pkgdir" \
+ .dist/termcolor*.whl
}
-sha512sums="4bd06bf4405a9ef6c005cd4d159ef602f7fc7fccb3e57586da1187c402f4d0b9051ef930cae423065c51ff4be8a22ceae556a61a6b3c8c519d623c066c340b53 termcolor-1.1.0.tar.gz"
+
+sha512sums="
+e715940ccc8863baae020345cabc8fc90b5bbbd5ef4b384de96920a90d97508cee6f863aa39a2c08971e58f45cf85ec73c0659715f54072bbc57612681138355 termcolor-2.4.0.tar.gz
+"