aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-testfixtures/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-testfixtures/APKBUILD')
-rw-r--r--community/py3-testfixtures/APKBUILD28
1 files changed, 20 insertions, 8 deletions
diff --git a/community/py3-testfixtures/APKBUILD b/community/py3-testfixtures/APKBUILD
index 79291ff760f..73ff8ac2c29 100644
--- a/community/py3-testfixtures/APKBUILD
+++ b/community/py3-testfixtures/APKBUILD
@@ -1,39 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer:
pkgname=py3-testfixtures
-pkgver=6.18.0
-pkgrel=0
+pkgver=7.2.2
+pkgrel=1
pkgdesc="Collection of helpers and mock objects for unit tests and doc tests"
url="https://github.com/Simplistix/testfixtures"
arch="noarch"
license="MIT"
depends="python3"
makedepends="
+ py3-gpep517
py3-setuptools
py3-sphinx
+ py3-wheel
"
checkdepends="
+ py3-django
py3-pytest
py3-sybil
py3-twisted
py3-zope-component
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/t/testfixtures/testfixtures-$pkgver.tar.gz"
builddir="$srcdir/testfixtures-$pkgver"
+options="!check" # inconsistent leeading whitespace
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- cd build/lib
- pytest --ignore="testfixtures/tests/test_django" # Fails to import
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ cd .testenv
+ bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+
+ rm -r "$pkgdir"/usr/lib/python3*/site-packages/testfixtures/tests/
}
sha512sums="
-e6552e6b1837ae4ee4754ce3675bdbf2a68d8e46b892382bd8320290050f2c296348ef6310ce3ff46962bf1978c351fe2cdb853a73c9f800f68818f81d5caec9 testfixtures-6.18.0.tar.gz
+4f7a5ed659b650080deac0b1caff6d2dff0b71d23eaeb26b48b7daa4df85dc0a1f6cfef98275c9a90289eb893c0a06311c849b84f2cc35447fb766f4d0d41c89 testfixtures-7.2.2.tar.gz
"