aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-texttable/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-texttable/APKBUILD')
-rw-r--r--community/py3-texttable/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/py3-texttable/APKBUILD b/community/py3-texttable/APKBUILD
index 843e2a4c7a4..f153785ee31 100644
--- a/community/py3-texttable/APKBUILD
+++ b/community/py3-texttable/APKBUILD
@@ -1,27 +1,35 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-texttable
-pkgver=1.6.3
+pkgver=1.7.0
pkgrel=1
pkgdesc="module for creating simple ASCII tables"
url="https://github.com/foutaise/texttable/"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.io/packages/source/t/texttable/texttable-$pkgver.tar.gz"
builddir="$srcdir/texttable-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- py.test-3 tests.py -v
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest tests.py -v
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="b7ca8d6c5e0835ebccf160efa658df54ff542729c6a9302f7473fa0c32acfe1762ac7ef69d94a274148a64d1bf4025d08059236efc8b9f3881d3cbec7b3db07a texttable-1.6.3.tar.gz"
+sha512sums="
+427ab262301bc38066c4a54e8ef10163579b5d6210aeb003a729dbaef8badd347a2d01f9ea1d9d136611fc104a3a8cf59a7a9acac6f76f64f9575dc6e5ab4313 texttable-1.7.0.tar.gz
+"