aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-texttable/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-texttable/APKBUILD')
-rw-r--r--community/py3-texttable/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-texttable/APKBUILD b/community/py3-texttable/APKBUILD
new file mode 100644
index 00000000000..bacbc144028
--- /dev/null
+++ b/community/py3-texttable/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-texttable
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="module for creating simple ASCII tables"
+url="https://github.com/foutaise/texttable/"
+arch="all"
+license="LGPL-3.0"
+depends="python3"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/t/texttable/texttable-$pkgver.tar.gz"
+builddir="$srcdir/texttable-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="41d1b429ee32cd717d273152da0263cfff13d79aae7ecc69bda455c1391ea1e6cf74b412e6043bf3d32d62932b4498a2484deb997ef545fdd6195fd5ebd58fc5 texttable-1.4.0.tar.gz"