aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tinydb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tinydb/APKBUILD')
-rw-r--r--community/py3-tinydb/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/py3-tinydb/APKBUILD b/community/py3-tinydb/APKBUILD
new file mode 100644
index 00000000000..addeb9c4b57
--- /dev/null
+++ b/community/py3-tinydb/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-tinydb
+pkgver=4.8.0
+pkgrel=1
+pkgdesc="a tiny, document oriented database"
+url="https://github.com/msiemens/tinydb"
+arch="noarch"
+license="MIT"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-poetry-core
+ py3-pytest-runner
+ py3-wheel
+ "
+checkdepends="
+ py3-pytest
+ py3-pytest-cov
+ py3-yaml
+ "
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/t/tinydb/tinydb-$pkgver.tar.gz"
+options="!check" # No tests in pypi package
+builddir="$srcdir/tinydb-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/tinydb*.whl
+}
+
+sha512sums="
+7f1932b766aba34f3721f0fbb7d45b8f39036caf8c41767e21232d4f329f00e440eb93a7284daa7b6df3a6700a5b4fcbdd6a7b79601ffd95480a86065cf7907c tinydb-4.8.0.tar.gz
+"