aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tldextract/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tldextract/APKBUILD')
-rw-r--r--community/py3-tldextract/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/py3-tldextract/APKBUILD b/community/py3-tldextract/APKBUILD
index f2b83f15c65..d0dec6c6505 100644
--- a/community/py3-tldextract/APKBUILD
+++ b/community/py3-tldextract/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=py3-tldextract
_pyname=tldextract
-pkgver=3.3.0
-pkgrel=0
+pkgver=5.1.2
+pkgrel=1
pkgdesc="Accurately separate the TLD from the registered domain and subdomains of a URL"
url="https://github.com/john-kurkowski/tldextract"
arch="noarch"
@@ -15,23 +15,29 @@ depends="
py3-requests-file
py3-filelock
"
-makedepends="py3-setuptools py3-setuptools_scm"
+makedepends="py3-gpep517 py3-setuptools py3-setuptools_scm py3-wheel"
checkdepends="py3-pytest py3-pytest-mock py3-responses"
+subpackages="$pkgname-pyc"
source="$_pyname-$pkgver.tar.gz::https://github.com/john-kurkowski/tldextract/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # Ignore release test as it depends on py3-syrupy in edge (and it's just a release script anyways).
+ .testenv/bin/python3 -m pytest --ignore tests/test_release.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-b5f9974ac7ea781e5a43f0bb4e66f1a392d0ed62c948732dd4bfe0f00413b254ffcdc20e1f778511aafcccec8aa0414e627b6dc829213c7f6b6c6697c2c31b1a tldextract-3.3.0.tar.gz
+0297087b7d825126131955316dc27e5f7e8f4124e107fd8ecadbd56d634e76ff6a9d70a23e117f7a5016badd6f599da84700681c9adfbfc927ae685cbeb3efb9 tldextract-5.1.2.tar.gz
"