aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tomli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tomli/APKBUILD')
-rw-r--r--community/py3-tomli/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/py3-tomli/APKBUILD b/community/py3-tomli/APKBUILD
index 032d7e835f2..d008ff763c2 100644
--- a/community/py3-tomli/APKBUILD
+++ b/community/py3-tomli/APKBUILD
@@ -1,32 +1,37 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-tomli
-_pyname=tomli
-pkgver=1.1.0
-pkgrel=0
+pkgver=2.0.1
+pkgrel=3
pkgdesc="Lil' TOML parser"
url="https://github.com/hukkin/tomli"
license="MIT"
arch="noarch"
depends="python3"
-makedepends="pyproject2setuppy"
-checkdepends="py3-pytest py3-dateutil"
-source="https://github.com/hukkin/tomli/archive/$pkgver/tomli-$pkgver.tar.gz"
-builddir="$srcdir/$_pyname-$pkgver"
+makedepends="py3-installer"
+subpackages="$pkgname-pyc"
+source="https://github.com/hukkin/tomli/archive/$pkgver/tomli-$pkgver.tar.gz
+ https://files.pythonhosted.org/packages/py3/t/tomli/tomli-$pkgver-py3-none-any.whl
+ "
+builddir="$srcdir/tomli-$pkgver"
build() {
- python3 -m pyproject2setuppy.main build
+ # both py3-pep517 and py3-flit need tomli, so we need to fetch the wheel
+ # directly from PyPI to avoid a circular dependency
+ return 0
}
check() {
- pytest
+ # use tests from GitHub tarball, but source code from wheel
+ unzip -q "$srcdir"/tomli-$pkgver-py3-none-any.whl -d "$srcdir"/wheel
+ PYTHONPATH="$srcdir/wheel" python3 -m unittest
}
package() {
- python3 -m pyproject2setuppy.main install \
- --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" "$srcdir"/tomli-$pkgver-py3-none-any.whl
}
sha512sums="
-bd452d7a2ded403f3028ef66eb3dfa710f638e40a5737a23572538c1e3f6c6e17f74be4a41fa1b62b117e6d16f123a7f34eae9f221725fbd94eb7c8a5821838c tomli-1.1.0.tar.gz
+a467f8d48cdbd7213bd9b6f85fd48ba142ab7c9656c40bb30785e1c4b37a9e29eaed420f183458ad20112baee8413ebbec87755332795c8f02235d1018c3aa5c tomli-2.0.1.tar.gz
+b6164b03d3db360093f92e644e87a37a0ce20d63d7e9e271fcafd727f4fdb73ad6b301aaf32b3d2839f6eedbc8ea499dafba7335b8fdfc4667e30ed50c9805b4 tomli-2.0.1-py3-none-any.whl
"