aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tqdm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tqdm/APKBUILD')
-rw-r--r--community/py3-tqdm/APKBUILD59
1 files changed, 33 insertions, 26 deletions
diff --git a/community/py3-tqdm/APKBUILD b/community/py3-tqdm/APKBUILD
index fafdb5b5dd3..02270ccbc89 100644
--- a/community/py3-tqdm/APKBUILD
+++ b/community/py3-tqdm/APKBUILD
@@ -1,17 +1,25 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=py3-tqdm
-_pkgname=tqdm
-pkgver=4.61.2
-pkgrel=0
+pkgver=4.66.2
+pkgrel=2
pkgdesc="Fast, Extensible Progress Meter"
-options="!check" # Broken on our current Python build due to setuptools version conflict
-url="https://pypi.python.org/pypi/tqdm"
+url="https://pypi.org/project/tqdm"
arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+makedepends="
+ py3-gpep517
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="
+ py3-pandas
+ py3-pytest
+ py3-pytest-asyncio
+ py3-pytest-timeout
+ "
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/t/tqdm/tqdm-$pkgver.tar.gz"
+builddir="$srcdir/tqdm-$pkgver"
replaces="py-tqdm" # Backwards compatibility
provides="py-tqdm=$pkgver-r$pkgrel" # Backwards compatibility
@@ -20,34 +28,33 @@ prepare() {
default_prepare
case "$CARCH" in
# FIXME: remove selected failing tests on selected arches
- aarch64) rm tests/tests_perf.py;;
- s390x) rm tests/tests_perf.py;;
- x86) rm tests/tests_synchronisation.py;;
+ aarch64) rm -v tests/tests_perf.py;;
+ s390x) rm -v tests/tests_perf.py;;
+ x86) rm -v tests/tests_synchronisation.py;;
esac
-
- # Remove dep on py3-setuptools_scm
- sed -e "s|use_scm_version=True|version='$pkgver'|" \
- -i setup.py
- sed -e '/setuptools_scm/d' -i setup.cfg
}
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver"
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+
+ # 30s timeout
+ .testenv/bin/python3 -m pytest -k 'not test_lock_args'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- mv "$pkgdir"/usr/bin/tqdm "$pkgdir"/usr/bin/tqdm-3
+ python3 -m installer -d "$pkgdir" .dist/*.whl
- mkdir -p "$pkgdir"/usr/bin
- ln -s tqdm-3 "$pkgdir"/usr/bin/tqdm
+ ln -s tqdm "$pkgdir"/usr/bin/tqdm-3
}
sha512sums="
-bc33e8fe00244f90f61ab51d0c7c0b98d5580efebd9758284d9dbe2a699eabeb0d92871eedc2f95f377e29dd0f7ea4b5247b96cb4cc1687dcfea3a9ed1152ab7 tqdm-4.61.2.tar.gz
+49abd9006ca7c8672835b202e4e722602035a0e21723337b4227e114d6d50b678edb6c5f2b0cf4e6741eae5e86551ba59233f87989f6b69bb4d4414d5a3c80e5 tqdm-4.66.2.tar.gz
"