aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tqdm
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tqdm')
-rw-r--r--community/py3-tqdm/APKBUILD49
1 files changed, 12 insertions, 37 deletions
diff --git a/community/py3-tqdm/APKBUILD b/community/py3-tqdm/APKBUILD
index 5187f7f9820..61943e50a37 100644
--- a/community/py3-tqdm/APKBUILD
+++ b/community/py3-tqdm/APKBUILD
@@ -1,22 +1,23 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py-tqdm
+pkgname=py3-tqdm
_pkgname=tqdm
pkgver=4.34.0
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, Extensible Progress Meter"
+options="!check" # Broken on our current Python build due to setuptools version conflict
url="https://pypi.python.org/pypi/tqdm"
arch="noarch"
license="MIT"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-tqdm" # Backwards compatibility
+provides="py-tqdm=$pkgver-r$pkgrel" # Backwards compatibility
+
prepare() {
default_prepare
- cd "$builddir"
-
case "$CARCH" in
# FIXME: remove selected failing tests on selected arches
aarch64) rm tqdm/tests/tests_perf.py;;
@@ -26,46 +27,20 @@ prepare() {
}
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
-
- python2 setup.py test
- # Broken on our current Python build due to setuptools version conflict
- #python3 setup.py test
+ python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"/usr/bin
- ln -s tqdm-3 "$pkgdir"/usr/bin/tqdm
-}
-
-_py() {
- local python="$1"
- local pyver="${python:6:1}"
- pkgdesc="$pkgdesc ($python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ mv "$pkgdir"/usr/bin/tqdm "$pkgdir"/usr/bin/tqdm-3
- cd "$subpkgdir"
-
- # Add version suffix to executable.
- mv usr/bin/tqdm usr/bin/tqdm-$pyver
-}
-
-_py2() {
- _py python2
-}
-
-_py3() {
- _py python3
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s tqdm-3 "$pkgdir"/usr/bin/tqdm
}
sha512sums="e89c5189faa596b5821a3c9ba1538f97f28df61928f6e1d028a2dbd649e59bd998e226359ddb0bd4e012ba77575d6610b1283d1289cd46f78b8f8fdf3bb3e4e7 tqdm-4.34.0.tar.gz