aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-treq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-treq/APKBUILD')
-rw-r--r--community/py3-treq/APKBUILD28
1 files changed, 21 insertions, 7 deletions
diff --git a/community/py3-treq/APKBUILD b/community/py3-treq/APKBUILD
index cf6da18d58a..e5c781f160c 100644
--- a/community/py3-treq/APKBUILD
+++ b/community/py3-treq/APKBUILD
@@ -1,24 +1,38 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
pkgname=py3-treq
-pkgver=18.6.0
-pkgrel=1
+pkgver=22.2.0
+pkgrel=4
pkgdesc="py3-requests-like API build on top of Twisted's HTTP client"
-options="!check" # Requires unpackaged httpbin
url="https://github.com/twisted/treq"
arch="noarch"
license="MIT"
-depends="python3 py3-incremental py3-requests py3-six py3-twisted py3-attrs"
+depends="python3 py3-incremental py3-requests py3-twisted py3-attrs"
makedepends="py3-setuptools"
+checkdepends="py3-httpbin py3-openssl py3-pytest py3-mock py3-service_identity py3-twisted-tests"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/twisted/treq/archive/release-$pkgver.tar.gz"
builddir="$srcdir/treq-release-$pkgver"
+# note(Leo): Replace the GHSA with CVEs once it comes out
+#
+# secfixes:
+# 22.1.0-r0:
+# - GHSA-fhpf-pp6p-55qc
+
build() {
python3 setup.py build
}
+check() {
+ rm -f src/treq/test/test_treq_integration.py
+ python3 -m pytest
+}
+
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="1d0d793725647c6b451853f166436040e49095fca43f6c74053f3ba18ec8f8ae0095ed78c7d141cc95dfba9674339ac44262943225bec7be0f0cb05253758688 py3-treq-18.6.0.tar.gz"
+sha512sums="
+fa69bde03be083236fee7bd8adfd549578eb46f7dbb51d2a5acb1923a8e7d047d81de0a0c9ac407ac7ac6f11a677ffa57a6203b7fd139534eb698d987f019d69 py3-treq-22.2.0.tar.gz
+"