aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-treq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-treq/APKBUILD')
-rw-r--r--community/py3-treq/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/py3-treq/APKBUILD b/community/py3-treq/APKBUILD
index 7f6bdc4e10b..e5c781f160c 100644
--- a/community/py3-treq/APKBUILD
+++ b/community/py3-treq/APKBUILD
@@ -1,18 +1,25 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
pkgname=py3-treq
-pkgver=21.1.0
-pkgrel=1
+pkgver=22.2.0
+pkgrel=4
pkgdesc="py3-requests-like API build on top of Twisted's HTTP client"
url="https://github.com/twisted/treq"
arch="noarch"
license="MIT"
-depends="python3 py3-incremental py3-requests py3-six py3-twisted py3-attrs"
+depends="python3 py3-incremental py3-requests py3-twisted py3-attrs"
makedepends="py3-setuptools"
-checkdepends="py3-httpbin py3-openssl py3-pytest py3-mock py3-service_identity"
+checkdepends="py3-httpbin py3-openssl py3-pytest py3-mock py3-service_identity py3-twisted-tests"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/twisted/treq/archive/release-$pkgver.tar.gz"
builddir="$srcdir/treq-release-$pkgver"
+# note(Leo): Replace the GHSA with CVEs once it comes out
+#
+# secfixes:
+# 22.1.0-r0:
+# - GHSA-fhpf-pp6p-55qc
+
build() {
python3 setup.py build
}
@@ -23,7 +30,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="9bcca6e4acd316529608654a15e70459693a877920bce262bdce505c2b6ad9397a84b9c4b24a56e123f98975a8271eb9306babd5808d840bff19117d7e64ff3f py3-treq-21.1.0.tar.gz"
+sha512sums="
+fa69bde03be083236fee7bd8adfd549578eb46f7dbb51d2a5acb1923a8e7d047d81de0a0c9ac407ac7ac6f11a677ffa57a6203b7fd139534eb698d987f019d69 py3-treq-22.2.0.tar.gz
+"