aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-trio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-trio/APKBUILD')
-rw-r--r--community/py3-trio/APKBUILD40
1 files changed, 28 insertions, 12 deletions
diff --git a/community/py3-trio/APKBUILD b/community/py3-trio/APKBUILD
index 2af7ecb7b04..efcdd991677 100644
--- a/community/py3-trio/APKBUILD
+++ b/community/py3-trio/APKBUILD
@@ -1,27 +1,37 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-trio
-pkgver=0.18.0
-pkgrel=1
+pkgver=0.25.0
+pkgrel=0
pkgdesc="A friendly Python library for async concurrency and I/O"
url="https://trio.readthedocs.io/"
arch="noarch"
license="MIT OR Apache-2.0"
depends="
+ py3-attrs
+ py3-async_generator
py3-idna
+ py3-cffi
py3-openssl
py3-outcome
py3-sniffio
py3-sortedcontainers
python3
"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="
py3-astor
py3-pytest
py3-trustme
"
-source="https://pypi.python.org/packages/source/t/trio/trio-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/t/trio/trio-$pkgver.tar.gz
+ fix-musl-getaddrinfo.patch
+ "
builddir="$srcdir/trio-$pkgver"
case "$CARCH" in
@@ -29,19 +39,25 @@ case "$CARCH" in
esac
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # test_fallback_when_no_hook_claims_it fails with pytest >= 6.2
- # https://github.com/python-trio/trio/issues/1843
- # https://github.com/python-trio/trio/pull/1824
- pytest -v -m "not redistributors_should_skip" \
- --deselect trio/_core/tests/test_asyncgen.py::test_fallback_when_no_hook_claims_it
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
+ --pyargs trio --skip-optional-imports \
+ -v -m "not redistributors_should_skip"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="48da018c0de25248f97fbafe93efff228535364f0e41a1ed266facfbd5981cf497a758fdcf64ae7bbdf7231d682adc6ae3ba97939d4bbef7347607bfacaa5630 trio-0.18.0.tar.gz"
+sha512sums="
+3025640724e628086d90136517dcb2083e1e47761305cd36c087c7f80d31013edd294e4fb7f1d27c28e6837c456be42d45e0f8529f88960fffe73c43ef37914d trio-0.25.0.tar.gz
+10740378902c4dfa7492ce6e41ef3c5cc959b185725193aff3ef29a91bd25ba3f35cf19ea31bcb9ad7ab2ca2509d11ed27112654d223a0315e2f539742a23c47 fix-musl-getaddrinfo.patch
+"