aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-twisted/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-twisted/APKBUILD')
-rw-r--r--community/py3-twisted/APKBUILD63
1 files changed, 48 insertions, 15 deletions
diff --git a/community/py3-twisted/APKBUILD b/community/py3-twisted/APKBUILD
index 727ba37ce4f..c87cef6b2bd 100644
--- a/community/py3-twisted/APKBUILD
+++ b/community/py3-twisted/APKBUILD
@@ -1,21 +1,37 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-twisted
-pkgver=21.2.0
-pkgrel=0
+pkgver=22.10.0
+pkgrel=4
pkgdesc="Asynchronous networking framework written in Python3"
-url="http://twistedmatrix.com/"
+url="https://twistedmatrix.com/"
arch="all"
license="MIT"
-depends="python3 py3-cryptography py3-zope-interface py3-constantly py3-incremental py3-attrs
- py3-pyhamcrest py3-hyperlink py3-automat py3-service_identity py3-idna"
-makedepends="libtirpc-dev py3-setuptools python3-dev cython"
+depends="
+ py3-cryptography
+ py3-zope-interface
+ py3-constantly
+ py3-incremental
+ py3-automat
+ py3-hyperlink
+ py3-attrs
+ py3-typing-extensions
+ py3-pyhamcrest
+ py3-service_identity
+ py3-idna
+ py3-pyserial
+ py3-h2
+ py3-setuptools
+ "
+makedepends="py3-gpep517 py3-wheel"
checkdepends="xvfb-run py3-appdirs tzdata py3-asn1 py3-bcrypt"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-tests $pkgname-pyc"
source="https://github.com/twisted/twisted/archive/twisted-$pkgver.tar.gz
disable-test-missing-ckeygen.patch
- skip-failing-test.patch
+ fix-test-import.patch
+ hanging-test.patch
"
builddir="$srcdir"/twisted-twisted-$pkgver
+options="!check" # bunch of random failures
replaces="py-twisted" # Backwards compatibility
provides="py-twisted=$pkgver-r$pkgrel" # Backwards compatibility
@@ -25,6 +41,12 @@ case "$CARCH" in
esac
# secfixes:
+# 22.4.0-r0:
+# - CVE-2022-24801
+# 22.2.0-r0:
+# - CVE-2022-21716
+# 22.1.0-r0:
+# - CVE-2022-21712
# 20.3.0-r0:
# - CVE-2020-10108
# - CVE-2020-10109
@@ -46,17 +68,20 @@ prepare() {
}
build() {
- find -name '*.pyx' -exec cython {} \;
- CFLAGS="$CFLAGS $(pkgconf --cflags libtirpc)" python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$(echo $PWD/build/lib*)" xvfb-run python3 \
+ PYTHONPATH="$(echo $PWD/build/lib*)" xvfb-run -a python3 \
-c 'from twisted.scripts.trial import run; run()' twisted
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/Twisted*.whl
+ # python3 setup.py install --skip-build --root="$pkgdir"
# Do not remove the test as it is a legitimate module and not
# a (common) packaging mistake by upstream
# rm -rf "$pkgdir"/usr/lib/python3*/site-packages/twisted/test
@@ -68,11 +93,19 @@ package() {
done
}
+tests() {
+ amove usr/lib/python3*/site-packages/twisted/test
+ amove usr/lib/python3*/site-packages/twisted/*/test
+}
+
doc() {
replaces="py-twisted-doc" # Backwards compatibility
default_doc
}
-sha512sums="fa743dcf22f3c17dfd17f39b7df0cc31fb8ce3e989478ada9a026424ec2de35e6a403ef35acdef5905eed008d42e3c2fee6b7ccdda433e6c250f1feaa83ea8a4 twisted-21.2.0.tar.gz
-a39c0f6615699bfbed13411cc6990756ce0e25dcd9d21dfce83b130ab8d0adeeb1e7fca1577732b02c886da52eeddd121987f861418ad85f93907e5a47bfcf02 disable-test-missing-ckeygen.patch
-0e2079a3d2790513b14de8803f42592ca638d0d9911ced0a60313efcdee41a9a159840aa9312cbc1bad6469a73aa706ca2f5a076952ad072158eca0a7664cdf9 skip-failing-test.patch"
+sha512sums="
+cf9ed96430376d499ae9627a7d0656c05cb99bc9e9b15a8f4166355363818f090bc3c2b383ed4cf19e1e38fb569e8618d35a0ddde2a90a06f3c9a4ea769837e4 twisted-22.10.0.tar.gz
+c432bbc2098bf7e36aaa51a548a5d60de4f790caf10fc9dfa04e11e88b4fbea4c4245106c1152ce4f450082dd8111d5f72b65c5c99ee2d0e5c8e0511ae821b6c disable-test-missing-ckeygen.patch
+a8e073ff8a35ad8faa95d023e9cf72dc3af0f0e4386fc0e66e57552eb9ff9ae1648b7c0809a5fbb6dca5799db7983280aefcabad1b52bf1187f25b62a4fe39a1 fix-test-import.patch
+523a4d89343cc2c9914e15fdfd25b9f89c9bee2a00d6b10c808ad4af4dd46689f5f0ebe529bd2ba4855dc7d80192e79f829192bc9171a5b2ae13dc04a181e352 hanging-test.patch
+"