aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-twisted/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-twisted/APKBUILD')
-rw-r--r--community/py3-twisted/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/py3-twisted/APKBUILD b/community/py3-twisted/APKBUILD
index 6e7430c78fe..f946d5592a4 100644
--- a/community/py3-twisted/APKBUILD
+++ b/community/py3-twisted/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-twisted
-pkgver=22.2.0
-pkgrel=0
+pkgver=22.10.0
+pkgrel=5
pkgdesc="Asynchronous networking framework written in Python3"
url="https://twistedmatrix.com/"
arch="all"
@@ -10,7 +10,7 @@ depends="
py3-cryptography
py3-zope-interface
py3-constantly
- py3-incremental>=21.3.0
+ py3-incremental
py3-automat
py3-hyperlink
py3-attrs
@@ -20,16 +20,18 @@ depends="
py3-idna
py3-pyserial
py3-h2
+ py3-setuptools
"
-makedepends="libtirpc-dev py3-setuptools python3-dev cython"
+makedepends="py3-gpep517 py3-wheel"
checkdepends="xvfb-run py3-appdirs tzdata py3-asn1 py3-bcrypt"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-tests $pkgname-pyc"
source="https://github.com/twisted/twisted/archive/twisted-$pkgver.tar.gz
disable-test-missing-ckeygen.patch
fix-test-import.patch
- remove-failing-test.patch
+ hanging-test.patch
"
builddir="$srcdir"/twisted-twisted-$pkgver
+options="!check" # bunch of random failures
replaces="py-twisted" # Backwards compatibility
provides="py-twisted=$pkgver-r$pkgrel" # Backwards compatibility
@@ -39,6 +41,8 @@ case "$CARCH" in
esac
# secfixes:
+# 22.4.0-r0:
+# - CVE-2022-24801
# 22.2.0-r0:
# - CVE-2022-21716
# 22.1.0-r0:
@@ -64,17 +68,20 @@ prepare() {
}
build() {
- find . -name '*.pyx' -exec cython {} \;
- CFLAGS="$CFLAGS $(pkgconf --cflags libtirpc)" python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$(echo $PWD/build/lib*)" xvfb-run python3 \
+ PYTHONPATH="$(echo $PWD/build/lib*)" xvfb-run -a python3 \
-c 'from twisted.scripts.trial import run; run()' twisted
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/Twisted*.whl
+ # python3 setup.py install --skip-build --root="$pkgdir"
# Do not remove the test as it is a legitimate module and not
# a (common) packaging mistake by upstream
# rm -rf "$pkgdir"/usr/lib/python3*/site-packages/twisted/test
@@ -86,14 +93,19 @@ package() {
done
}
+tests() {
+ amove usr/lib/python3*/site-packages/twisted/test
+ amove usr/lib/python3*/site-packages/twisted/*/test
+}
+
doc() {
replaces="py-twisted-doc" # Backwards compatibility
default_doc
}
sha512sums="
-a2f66055f0ea6658a04888316b9eb90bd0f389c72db8315fe1722a70f16bb290805d98acc8cfd8a5d22b4817683603aaea50bb04a204927898bd74fc58a1db6d twisted-22.2.0.tar.gz
+cf9ed96430376d499ae9627a7d0656c05cb99bc9e9b15a8f4166355363818f090bc3c2b383ed4cf19e1e38fb569e8618d35a0ddde2a90a06f3c9a4ea769837e4 twisted-22.10.0.tar.gz
c432bbc2098bf7e36aaa51a548a5d60de4f790caf10fc9dfa04e11e88b4fbea4c4245106c1152ce4f450082dd8111d5f72b65c5c99ee2d0e5c8e0511ae821b6c disable-test-missing-ckeygen.patch
a8e073ff8a35ad8faa95d023e9cf72dc3af0f0e4386fc0e66e57552eb9ff9ae1648b7c0809a5fbb6dca5799db7983280aefcabad1b52bf1187f25b62a4fe39a1 fix-test-import.patch
-eeaf81c9599930f8645c8bf14baa25c6f66aaf3d396266124b825c8e672082ecab9d2cf5aa5d3be9c2a81d4c51afd7de1f68ee3699c773c406d7febea59230e1 remove-failing-test.patch
+523a4d89343cc2c9914e15fdfd25b9f89c9bee2a00d6b10c808ad4af4dd46689f5f0ebe529bd2ba4855dc7d80192e79f829192bc9171a5b2ae13dc04a181e352 hanging-test.patch
"