aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-txacme/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-txacme/APKBUILD')
-rw-r--r--community/py3-txacme/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/community/py3-txacme/APKBUILD b/community/py3-txacme/APKBUILD
index e49e023779e..3382784164e 100644
--- a/community/py3-txacme/APKBUILD
+++ b/community/py3-txacme/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer:
pkgname=py3-txacme
pkgver=0.9.3
-pkgrel=3
+pkgrel=8
pkgdesc="ACME protocol implementation for Twisted"
options="!check" # Requires unpackaged dependencies
-url="https://github.com/mithrandi/txacme"
+url="https://github.com/twisted/txacme"
arch="noarch"
license="MIT"
depends="
@@ -20,16 +20,24 @@ depends="
py3-txsni
py3-openssl
"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-python-versioneer"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/twisted/txacme/archive/$pkgver.tar.gz"
builddir="$srcdir/txacme-$pkgver"
+prepare() {
+ default_prepare
+
+ # unvendor
+ rm versioneer.py
+}
+
build() {
python3 setup.py build
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="b0a6c6401a9a6d8f8a59c29e34aaf398778f327f5907d4406273b4d0fce6c8449d388a5a687efb25bab5799fd7ddf9a0e2ce482a9b1457d93875a05f593dfa1c py3-txacme-0.9.3.tar.gz"