aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-txsni/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-txsni/APKBUILD')
-rw-r--r--community/py3-txsni/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/py3-txsni/APKBUILD b/community/py3-txsni/APKBUILD
new file mode 100644
index 00000000000..cd6b2018f8f
--- /dev/null
+++ b/community/py3-txsni/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-txsni
+pkgver=0.2.0
+pkgrel=6
+pkgdesc="Simple support for running a TLS server with Twisted"
+options="!check" # No testsuite
+url="https://github.com/glyph/txsni"
+arch="noarch"
+license="MIT"
+depends="python3 py3-openssl py3-twisted"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/T/TxSNI/TxSNI-$pkgver.tar.gz"
+builddir="$srcdir/TxSNI-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="3fe725b4c24c3d12e533b29dcc547288033be5b641988eb37b53a7cce9bce055689dd320d41ea7390888710805a754e236755936c64648dc271d97c28e0a2a44 TxSNI-0.2.0.tar.gz"