aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-typed-ast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-typed-ast/APKBUILD')
-rw-r--r--community/py3-typed-ast/APKBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/community/py3-typed-ast/APKBUILD b/community/py3-typed-ast/APKBUILD
index a9b7467ffab..38d7cc59f03 100644
--- a/community/py3-typed-ast/APKBUILD
+++ b/community/py3-typed-ast/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-typed-ast
_pkgname=typed_ast
-pkgver=1.4.2
+pkgver=1.5.5
pkgrel=1
pkgdesc="Fork of the Python ast module with type comment support"
url="https://github.com/python/typed_ast"
@@ -11,29 +11,27 @@ license="Apache-2.0"
depends="python3"
makedepends="py3-setuptools python3-dev"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/"$_pkgname-$pkgver
+# two (2) tests fail on s390x, disable
+case "$CARCH" in
+s390x) options="$options !check" ;;
+esac
+
build() {
python3 setup.py build
}
-# two (2) tests fail on s390x, disable
check() {
- local _pyarch
- local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
- case "$CARCH" in
- x86_64|aarch64|ppc64le) _pyarch="$CARCH" ;;
- x86) _pyarch=i686 ;;
- armhf|armv7) _pyarch=armv8l ;;
- s390x) return 0 ;;
- mips*) return 0 ;;
- esac
- PYTHONPATH="$builddir/build/lib.linux-$_pyarch-$_py3ver" py.test-3 -v
+ PYTHONPATH=$(echo build/lib*) pytest -v
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="9a46f2a4c48bd267445a773463771824be958dfdd1a2df21356d0a763ee2029b51d5b0fddeb16df202f89ba86019640ab45ba520fdad5c550250fe2a135605fe typed_ast-1.4.2.tar.gz"
+sha512sums="
+df0faae882c2f367fd5dc0aeeed12806307c739bfe2f466e199821f4197280e3d82fceee83580face3ef7b5bf184b29477f0828766f2b8991c3fbb2a4265eb3c typed_ast-1.5.5.tar.gz
+"