aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tzlocal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tzlocal/APKBUILD')
-rw-r--r--community/py3-tzlocal/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-tzlocal/APKBUILD b/community/py3-tzlocal/APKBUILD
new file mode 100644
index 00000000000..bc99da3aeca
--- /dev/null
+++ b/community/py3-tzlocal/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-tzlocal
+pkgver=5.2
+pkgrel=1
+pkgdesc="Python tzinfo object for the local timezone"
+url="https://github.com/regebro/tzlocal"
+arch="noarch"
+license="MIT"
+replaces="py-tzlocal" # for backwards compatibility
+provides="py-tzlocal=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3 py3-tzdata"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/tzlocal/tzlocal-$pkgver.tar.gz"
+builddir="$srcdir/tzlocal-$pkgver"
+options="!check" # the package requires a configured timezone
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+4b2109d1d01941843e11f592e3e0ee412dfdc98db4f6529b96410e3a55eb770865de36c8440ac5fed1132b0a52f1dbcb8bc3212275c32f0fed611dc22605e3b4 py3-tzlocal-5.2.tar.gz
+"