aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ujson/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ujson/APKBUILD')
-rw-r--r--community/py3-ujson/APKBUILD26
1 files changed, 21 insertions, 5 deletions
diff --git a/community/py3-ujson/APKBUILD b/community/py3-ujson/APKBUILD
index d19d72c5a50..f575dd4a353 100644
--- a/community/py3-ujson/APKBUILD
+++ b/community/py3-ujson/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-ujson
-pkgver=4.0.2
+pkgver=5.9.0
pkgrel=1
pkgdesc="Fast Python JSON encoder and decoder"
url="https://github.com/ultrajson/ultrajson"
arch="all"
license="BSD-3-Clause"
makedepends="
+ py3-gpep517
py3-setuptools
py3-setuptools_scm
+ py3-wheel
python3-dev
"
checkdepends="
@@ -19,16 +21,30 @@ checkdepends="
source="https://pypi.io/packages/source/u/ujson/ujson-$pkgver.tar.gz"
builddir="$srcdir/ujson-$pkgver"
+# secfixes:
+# 5.4.0-r0:
+# - CVE-2022-31116
+# - CVE-2022-31117
+# 5.2.0-r0:
+# - CVE-2021-45958
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$(echo $PWD/build/lib.*)" python3 tests/test_ujson.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ece12d4407cb7cdb647597ff7fc32e4390fc4c790c59e764da5c5644e5dec470c48cb6a6aaa18429cb713643e5205c5d26b2d2d2195bc90f3a171615d3dbd80d ujson-4.0.2.tar.gz"
+sha512sums="
+9940bc0c892341a6d2b85cfe592888866f02f054f1367812c39395eaee946f7c66a0197b2791bbb765ae38a06dcd871145effefbc06c71a87f7d24be105cda1f ujson-5.9.0.tar.gz
+"