aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-unidecode/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-unidecode/APKBUILD')
-rw-r--r--community/py3-unidecode/APKBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/community/py3-unidecode/APKBUILD b/community/py3-unidecode/APKBUILD
index 9608812cef4..1d8a4b24131 100644
--- a/community/py3-unidecode/APKBUILD
+++ b/community/py3-unidecode/APKBUILD
@@ -2,35 +2,35 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-unidecode
_pkgname=Unidecode
-pkgver=1.1.2
-pkgrel=2
+pkgver=1.3.8
+pkgrel=1
pkgdesc="Python3 ASCII transliterations of Unicode text"
-url="https://pypi.python.org/pypi/Unidecode"
+url="https://pypi.org/project/Unidecode"
arch="noarch"
license="GPL-2.0-or-later"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- # Add version suffix to executable files.
- local path; for path in "$pkgdir"/usr/bin/*; do
- mv "$path" "$path"-3
- done
-
- mkdir -p "$pkgdir"/usr/bin
- ln -s unidecode-3 "$pkgdir"/usr/bin/unidecode
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="8ee45ae05064612638ecbaa4eb74759580e5ea5cba9f3116b8e63db4af13affc266c7a07aaefbbd70b50ead7e483a72d7676c64e20b5bee2a6ba831aaccd6748 Unidecode-1.1.2.tar.gz"
+sha512sums="
+0c93647b05b3ce041ba0091705630a4d75dfc249b3aa57b1d8bd26d26f1a067af1d0103a0f57ee2ea07224797ce204562e08df92d0fe60e250a16614bf146ece Unidecode-1.3.8.tar.gz
+"