aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-unidecode/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-unidecode/APKBUILD')
-rw-r--r--community/py3-unidecode/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-unidecode/APKBUILD b/community/py3-unidecode/APKBUILD
new file mode 100644
index 00000000000..30beed8c44a
--- /dev/null
+++ b/community/py3-unidecode/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-unidecode
+_pkgname=Unidecode
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Python3 ASCII transliterations of Unicode text"
+url="https://pypi.python.org/pypi/Unidecode"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="python3 py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ # Add version suffix to executable files.
+ local path; for path in "$pkgdir"/usr/bin/*; do
+ mv "$path" "$path"-3
+ done
+
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s unidecode-3 "$pkgdir"/usr/bin/unidecode
+}
+
+sha512sums="5474f04be843ed94ddceb1a7e5f1ca986ee5f2e88ee35bd9347784c7a11b51e1d94d61e1a2a10dd2e71b3587c5b7b76717756f6cf4e2446d83222178c2360696 Unidecode-1.1.1.tar.gz"