aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-unpaddedbase64/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-unpaddedbase64/APKBUILD')
-rw-r--r--community/py3-unpaddedbase64/APKBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/community/py3-unpaddedbase64/APKBUILD b/community/py3-unpaddedbase64/APKBUILD
index 7c4f4e57045..6966a5e1d0a 100644
--- a/community/py3-unpaddedbase64/APKBUILD
+++ b/community/py3-unpaddedbase64/APKBUILD
@@ -1,28 +1,36 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=py3-unpaddedbase64
pkgver=2.1.0
-pkgrel=0
+pkgrel=7
pkgdesc="Base64 Encoding and Decoding without = padding"
url="https://github.com/matrix-org/python-unpaddedbase64"
arch="noarch"
license="Apache-2.0"
-depends="python3"
-makedepends="pyproject2setuppy"
+makedepends="
+ py3-gpep517
+ py3-poetry-core
+ "
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/matrix-org/python-unpaddedbase64/archive/v$pkgver.tar.gz"
builddir="$srcdir/python-unpaddedbase64-$pkgver"
build() {
- python3 -m pyproject2setuppy.main build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pyproject2setuppy.main test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 -m pyproject2setuppy.main install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="