aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-update-checker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-update-checker/APKBUILD')
-rw-r--r--community/py3-update-checker/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-update-checker/APKBUILD b/community/py3-update-checker/APKBUILD
index 8bb38fdaff7..5f9ad8471f2 100644
--- a/community/py3-update-checker/APKBUILD
+++ b/community/py3-update-checker/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-update-checker
_pyname=update_checker
pkgver=0.18.0
-pkgrel=1
+pkgrel=5
pkgdesc="A python module that will check for package updates"
options="!check" # 4 tests fail
url="https://github.com/bboe/update_checker"
@@ -11,6 +11,7 @@ arch="noarch"
license="BSD-2-Clause"
depends="python3 py3-requests"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/u/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -26,7 +27,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="ab77b4904f27fc3a4f382dda08cf86fceedc6fa1c6a1f2b1d6ea42688f95ea1fbef4168d69233aec4a489d9ff7f93af60e8f1bf62854aa4d2f54136c540d26f1 update_checker-0.18.0.tar.gz"