aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-urwid_readline/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-urwid_readline/APKBUILD')
-rw-r--r--community/py3-urwid_readline/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-urwid_readline/APKBUILD b/community/py3-urwid_readline/APKBUILD
new file mode 100644
index 00000000000..f2f1fcd64f2
--- /dev/null
+++ b/community/py3-urwid_readline/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: omni <omni+alpine@hack.org>
+# Maintainer: omni <omni+alpine@hack.org>
+pkgname=py3-urwid_readline
+_pkgname=urwid_readline
+pkgver=0.14
+pkgrel=1
+pkgdesc="text input widget for urwid that supports readline shortcuts"
+url="https://github.com/rr-/urwid_readline"
+arch="noarch"
+license="MIT"
+depends="python3 py3-urwid"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-pytest-runner"
+#options="!check" # no test suite
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rr-/urwid_readline/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+cc24cc72110f6cecbd71f6bda355adc74acf9697dd0636c35a679767e1406a4a15ef53fb03e2e69d20a523f09020fe17b9cf6ac41f1516af52ed9b9736c77d14 py3-urwid_readline-0.14.tar.gz
+"