aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-virtualenv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-virtualenv/APKBUILD')
-rw-r--r--community/py3-virtualenv/APKBUILD50
1 files changed, 30 insertions, 20 deletions
diff --git a/community/py3-virtualenv/APKBUILD b/community/py3-virtualenv/APKBUILD
index 3e16ea2ec95..3c3f541c3be 100644
--- a/community/py3-virtualenv/APKBUILD
+++ b/community/py3-virtualenv/APKBUILD
@@ -1,44 +1,54 @@
# Contributor: Sam Dodrill <shadowh511@gmail.com>
# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer: Sam Dodrill <shadowh511@gmail.com>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-virtualenv
-pkgver=20.14.1
-pkgrel=0
+pkgver=20.25.1
+pkgrel=2
pkgdesc="Virtual Python3 Environment builder"
-options="!check" # Requires unpackaged 'flaky'
url="https://virtualenv.pypa.io/en/latest/"
arch="noarch"
license="MIT"
-depends="python3 py3-platformdirs py3-distlib py3-filelock py3-six"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
+depends="py3-platformdirs py3-distlib py3-filelock"
+makedepends="
+ py3-gpep517
+ py3-hatchling
+ py3-hatch-vcs
+ py3-wheel
+ "
+checkdepends="
+ py3-flaky
+ py3-pytest-env
+ py3-pytest-mock
+ py3-pytest-timeout
+ py3-pytest-xdist
+ py3-time-machine
+ python3-dev
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/v/virtualenv/virtualenv-$pkgver.tar.gz"
builddir="$srcdir/virtualenv-$pkgver"
replaces="py-virtualenv" # Backwards compatibility
provides="py-virtualenv=$pkgver-r$pkgrel" # Backwards compatibility
-prepare() {
- default_prepare
-
- sed -e '/setuptools_scm/d' \
- -e '/use_scm_verison=/,/}/d' \
- -i setup.py
- sed -i "/^\[metadata\]/a version = $pkgver" setup.cfg
-}
-
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto -v \
+ -k "not test_can_build_c_extensions"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-149e78787db23eabd4238baa172bf023ddcf87d59284fdd090269acfa15991aab182f9e168851f88ef810d5c50dd7cdce69d132c46ebedb10080d65a308e63a1 virtualenv-20.14.1.tar.gz
+c0791de2aed7893658316199696906b1aed650460f3b53e0dbd13e695d16bc14d8974cd72fc8dcc010ff7ba10036121929ce9a608f97d7d2cd9f972144a3a1f0 virtualenv-20.25.1.tar.gz
"