aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-voxpopuli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-voxpopuli/APKBUILD')
-rw-r--r--community/py3-voxpopuli/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-voxpopuli/APKBUILD b/community/py3-voxpopuli/APKBUILD
new file mode 100644
index 00000000000..bfb782db840
--- /dev/null
+++ b/community/py3-voxpopuli/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-voxpopuli
+pkgver=0.3.6
+pkgrel=5
+pkgdesc="A wrapper around Espeak and Mbrola, to do simple Text-To-Speech (TTS), with the possibility to tweak the phonemic form"
+url="https://github.com/hadware/voxpopuli"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="
+ mbrola-voices
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/hadware/voxpopuli/archive/v$pkgver/voxpopuli-v$pkgver.tar.gz"
+options="!check" # Requires mbrola which doesn't currently compile
+builddir="$srcdir/voxpopuli-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" pytest tests/tests.py
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="9ef82ab33304da31db82efdf1a0816da5631f4c3344f4373a27bcd03d95c0711b74e9f61cdfdb01aef17759a1054e3406426d8db9893a9e1224756239ca66eec voxpopuli-v0.3.6.tar.gz"