aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-websocket-client/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-websocket-client/APKBUILD')
-rw-r--r--community/py3-websocket-client/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/py3-websocket-client/APKBUILD b/community/py3-websocket-client/APKBUILD
index be6957f3dc0..1708a349664 100644
--- a/community/py3-websocket-client/APKBUILD
+++ b/community/py3-websocket-client/APKBUILD
@@ -1,33 +1,42 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-websocket-client
-pkgver=1.3.2
+pkgver=1.7.0
pkgrel=0
pkgdesc="WebSocket client library for Python"
url="https://github.com/websocket-client/websocket-client"
arch="noarch"
license="Apache-2.0"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="
py3-python-socks
- pytest
"
+subpackages="$pkgname-pyc"
source="https://github.com/websocket-client/websocket-client/archive/v$pkgver/websocket-client-v$pkgver.tar.gz"
builddir="$srcdir/websocket-client-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" pytest websocket/tests
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest discover
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -r "$pkgdir"/usr/lib/python3*/site-packages/websocket/tests
}
sha512sums="
-b12d343da2668bd2f3bc49472a092cfeee12fe651ddf9be4bae671a4b75b256c00706a48211c745b5ed0968b2cbee3ee173b2ec6a68f9316dc255a042d73fbba websocket-client-v1.3.2.tar.gz
+13208a17dcabf60fcd5202dbd1a296b9f39f95fc0fccabc11f8bcc16f69bef4d2a2b4ccd633eaea45fe8a2216793dca3574b22b29c099617178461340f702cad websocket-client-v1.7.0.tar.gz
"