aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-websocket-client/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-websocket-client/APKBUILD')
-rw-r--r--community/py3-websocket-client/APKBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/community/py3-websocket-client/APKBUILD b/community/py3-websocket-client/APKBUILD
index 0865a069dfb..3f72e82ef05 100644
--- a/community/py3-websocket-client/APKBUILD
+++ b/community/py3-websocket-client/APKBUILD
@@ -1,31 +1,42 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-websocket-client
-_pkgname=websocket_client
-pkgver=0.58.0
+pkgver=1.7.0
pkgrel=1
pkgdesc="WebSocket client library for Python"
-url="https://github.com/liris/websocket-client"
+url="https://github.com/websocket-client/websocket-client"
arch="noarch"
-license="BSD-3-Clause"
-depends="python3 py3-six"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/w/websocket-client/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+license="Apache-2.0"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-python-socks
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/websocket-client/websocket-client/archive/v$pkgver/websocket-client-v$pkgver.tar.gz"
+builddir="$srcdir/websocket-client-$pkgver"
-replaces="py-websocket-client" # Backwards compatibility
-provides="py-websocket-client=$pkgver-r$pkgrel" # Backwards compatibility
-
-check() {
- python3 setup.py check
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-build() {
- python3 setup.py build
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest discover
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -r "$pkgdir"/usr/lib/python3*/site-packages/websocket/tests
}
-sha512sums="c587945831427a9bddef96be53d20fec7f55ffd7efe2b676dac96b8078ba446ecda85379a4edfc49c36de936516d3994cbd0515decb9b615cd969bde1117167a websocket_client-0.58.0.tar.gz"
+sha512sums="
+13208a17dcabf60fcd5202dbd1a296b9f39f95fc0fccabc11f8bcc16f69bef4d2a2b4ccd633eaea45fe8a2216793dca3574b22b29c099617178461340f702cad websocket-client-v1.7.0.tar.gz
+"