aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-websockets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-websockets/APKBUILD')
-rw-r--r--community/py3-websockets/APKBUILD41
1 files changed, 27 insertions, 14 deletions
diff --git a/community/py3-websockets/APKBUILD b/community/py3-websockets/APKBUILD
index 5d6258839c7..98a06cbd022 100644
--- a/community/py3-websockets/APKBUILD
+++ b/community/py3-websockets/APKBUILD
@@ -1,35 +1,48 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: fossdd <fossdd@pwned.life>
+# Maintainer: fossdd <fossdd@pwned.life>
pkgname=py3-websockets
_pkgname=websockets
-pkgver=10.2
-pkgrel=0
+pkgver=12.0
+pkgrel=2
pkgdesc="An implementation of the WebSocket Protocol (RFC 6455)"
-options="net"
-url="https://websockets.readthedocs.io"
+url="https://websockets.readthedocs.io/"
arch="all"
license="BSD-3-Clause"
-makedepends="python3-dev py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/aaugustin/websockets/archive/$pkgver.tar.gz"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/aaugustin/websockets/archive/$pkgver.tar.gz
+ skip-reconnect-test.patch
+ "
builddir="$srcdir"/$_pkgname-$pkgver
+options="!check" # fail for now with context manager errors
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Tests fails because of legacy code
- rm -f tests/legacy/test_client_server.py tests/legacy/test_auth.py
-
export WEBSOCKETS_TESTS_TIMEOUT_FACTOR=30
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --root="$pkgdir" --optimize=1
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-b8c7fbe627e1c411112b0d66e561aa9bcf15d6de07a9cccd203211e0e6af49762774e09f8c5f4523fe214731ae7a96ed4b63639c7ed66fee062cdda3e5fba350 py3-websockets-10.2.tar.gz
+f17943d444ce275b709cf89453b2d2cce09f5af26f0460e226c2e24cfbb425c825963352e130dcd4201587606355375b525d8e5a02eccbffbb3985a108a3ed5e py3-websockets-12.0.tar.gz
+0849fa337f6a00297774cc3a3dd61497bbc99dc3b12632a385056a82e50fd04bf057068eeef6f9b705c257e3017b127ee38183461615d09549145889767bdc0b skip-reconnect-test.patch
"