aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-webtest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-webtest/APKBUILD')
-rw-r--r--community/py3-webtest/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/py3-webtest/APKBUILD b/community/py3-webtest/APKBUILD
new file mode 100644
index 00000000000..da65633db69
--- /dev/null
+++ b/community/py3-webtest/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-webtest
+pkgver=3.0.0
+pkgrel=4
+pkgdesc="A Helper to test WSGI applications"
+url="http://webtest.pythonpaste.org/"
+arch="noarch"
+license="MIT"
+depends="python3 py3-beautifulsoup4 py3-waitress py3-webob"
+makedepends="py3-setuptools"
+checkdepends="py3-lxml py3-paste py3-pastedeploy py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://pypi.io/packages/source/W/WebTest/WebTest-$pkgver.tar.gz"
+
+replaces="py-webtest" # Backwards compat
+provides="py-webtest=$pkgver-r$pkgrel" # Backwards compat
+
+builddir="$srcdir"/WebTest-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ # disable tests that requires wsgiproxy2 to avoid circular dependency
+ pytest -v \
+ --deselect tests/test_app.py \
+ --deselect tests/test_authorisation.py \
+ --deselect tests/test_debugapp.py \
+ --deselect tests/test_forms.py \
+ --deselect tests/test_lint.py \
+ --deselect tests/test_response.py
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+b97a6311d7e3bf653bec93c2390fb75c991d0dea6148680d8b6ff87861c130518a5d150dd157eab9b032b278566ad12c0ac8f5fc2ddbeba31e35de1e1f06f747 WebTest-3.0.0.tar.gz
+"