aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-werkzeug/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-werkzeug/APKBUILD')
-rw-r--r--community/py3-werkzeug/APKBUILD46
1 files changed, 33 insertions, 13 deletions
diff --git a/community/py3-werkzeug/APKBUILD b/community/py3-werkzeug/APKBUILD
index 2bac0174e98..00b713005a8 100644
--- a/community/py3-werkzeug/APKBUILD
+++ b/community/py3-werkzeug/APKBUILD
@@ -1,35 +1,55 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-werkzeug
-_pkgname=Werkzeug
-pkgver=2.0.1
+_pkgname=werkzeug
+pkgver=3.0.2
pkgrel=0
pkgdesc="The WSGI swiss-army knife"
-options="!check" # Tests fail with newer py3-packaging
url="https://werkzeug.palletsprojects.com/"
arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-requests"
+depends="python3 py3-markupsafe"
+makedepends="py3-gpep517 py3-flit-core"
+checkdepends="py3-pytest py3-requests py3-pytest-timeout"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-werkzeug" # Backwards compatibility
provides="py-werkzeug=$pkgver-r$pkgrel" # Backwards compatibility
-build() {
- python3 setup.py build
+# secfixes:
+# 2.2.2-r0:
+# - CVE-2022-29361
+# 2.3.7-r0:
+# - CVE-2023-46136
+
+prepare() {
+ default_prepare
+ # requires ephemeral-port-preserve
+ rm -fv tests/conftest.py
+ rm -fv tests/test_debug.py
+ # requires various pytest plugins
+ rm -fv tests/test_serving.py
+ rm -fv tests//middleware/test_http_proxy.py
}
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- fail="tests/test_debug.py" # needs testing/py3-pytest-timeout
- PYTHONPATH=$PWD/build/lib pytest --ignore="$fail"
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-6fb1e4fafcc352b47f2600d13db633ee2fcbcd678d453859415f792654de62135c89443ba15341efb7ff10270ae5cbf8d5120608d7dfab347d98af650f4d69f6 Werkzeug-2.0.1.tar.gz
+5f9a91684653da17ef419459db11a6a4bd83b6c1f2f6b0e9f0a296bc5c7c63d2b465044a131f579557f1fb240a560793b734f3d0248ecbb7b6af62b1713484c3 werkzeug-3.0.2.tar.gz
"