aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-whatever/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-whatever/APKBUILD')
-rw-r--r--community/py3-whatever/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-whatever/APKBUILD b/community/py3-whatever/APKBUILD
index bb2d1b22028..b815c9d6417 100644
--- a/community/py3-whatever/APKBUILD
+++ b/community/py3-whatever/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-whatever
_pkgname=whatever
-pkgver=0.6
-pkgrel=1
+pkgver=0.7
+pkgrel=2
pkgdesc="Easy anonymous functions by partial application of operators"
url="https://github.com/Suor/whatever"
arch="noarch"
@@ -11,6 +11,7 @@ license="BSD-3-Clause"
depends="python3"
checkdepends="py3-pytest"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://github.com/Suor/whatever/archive/$pkgver/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -23,7 +24,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="f982100f0d6a8bf4c30e452a083c75f4cb2bca07e57e40ba4fd66baca752f039aea9519ffb97b3d43708df0ff5e981d0c4d03773f225106aa2f43e7770ee1975 whatever-0.6.tar.gz"
+sha512sums="
+7641957f6eabad0d8485dac9b9cfaf0c6a8426ec9817c4e0748e669561fb5fbe21932f9bb864362ee34f5a5bff8ce6f6803c428130c1af3aabef3d583d7a582e whatever-0.7.tar.gz
+"