aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-wolframalpha/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-wolframalpha/APKBUILD')
-rw-r--r--community/py3-wolframalpha/APKBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/community/py3-wolframalpha/APKBUILD b/community/py3-wolframalpha/APKBUILD
deleted file mode 100644
index 56b84309bdc..00000000000
--- a/community/py3-wolframalpha/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=py3-wolframalpha
-pkgver=4.0.0
-pkgrel=1
-pkgdesc="Wolfram|Alpha 2.0 API client"
-url="https://github.com/jaraco/wolframalpha"
-arch="noarch"
-license="MIT"
-depends="python3 py3-xmltodict py3-jaraco-itertools"
-makedepends="py3-setuptools py3-setuptools_scm py3-toml"
-checkdepends="py3-pytest py3-pytest-black py3-pytest-flake8 py3-pytest-cov"
-source="https://pypi.python.org/packages/source/w/wolframalpha/wolframalpha-$pkgver.tar.gz"
-options="!check" # Flake8 failures I do not yet know how to resolve
-builddir="$srcdir/wolframalpha-$pkgver"
-
-build() {
- python3 setup.py build
-}
-
-check() {
- pytest \
- --ignore wolframalpha/test_pmxbot.py \
- --ignore wolframalpha/pmxbot.py
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="41fa275f9fe05e3eb37d7fd02c9e5883e7828be60a94fab70b454e112c5b59378866c834c35b8c9c93db08ae7c13e635755b033527f2a3b4089e43863f329a31 wolframalpha-4.0.0.tar.gz"