aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-wrapt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-wrapt/APKBUILD')
-rw-r--r--community/py3-wrapt/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/py3-wrapt/APKBUILD b/community/py3-wrapt/APKBUILD
index 565eb14f7af..5ff053a657a 100644
--- a/community/py3-wrapt/APKBUILD
+++ b/community/py3-wrapt/APKBUILD
@@ -2,31 +2,36 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-wrapt
_pkgname=wrapt
-pkgver=1.12.1
+pkgver=1.16.0
pkgrel=1
pkgdesc="Module for decorators, wrappers and monkey patching"
url="https://github.com/GrahamDumpleton/wrapt"
arch="all"
license="BSD-2-Clause"
depends="python3"
-makedepends="python3-dev"
+makedepends="python3-dev py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest"
-source="https://github.com/GrahamDumpleton/wrapt/archive/$pkgver/py3-wrapt-$pkgver.tar.gz
- python-3.9.patch
- "
+subpackages="$pkgname-pyc"
+source="https://github.com/GrahamDumpleton/wrapt/archive/$pkgver/py3-wrapt-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$(echo $PWD/build/lib*)" py.test-3 -v
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="33e964cb3aa2437bc7d084a98f622f7c5c8c719d97806796ae0317d35130bdb2679a9dd87be7077e2cae1eb32b65d152349fa7cc138cb392d5999cbfdcecc9ac py3-wrapt-1.12.1.tar.gz
-372323f80578bc1fe2fdf8d3a5dc67b79956180048f8036be429b3e2fed4c9f3ce3d29a2c9e8b6128a2ab64cf7d21dc1e7026e8df14a062a94bd8518aca5b50a python-3.9.patch"
+sha512sums="
+65bdda3b6580748ceb720e8fc1a6b05832a355d541aa650bc87052f3aa8793d03d29a080b79eceb16392e297aed8f11a283e36f5f40a0db614b409b1dc2b6c9c py3-wrapt-1.16.0.tar.gz
+"