aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ws4py/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ws4py/APKBUILD')
-rw-r--r--community/py3-ws4py/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-ws4py/APKBUILD b/community/py3-ws4py/APKBUILD
index 3e50114ceaa..33df8501f2f 100644
--- a/community/py3-ws4py/APKBUILD
+++ b/community/py3-ws4py/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-ws4py
_pkgname=ws4py
pkgver=0.5.1
-pkgrel=4
+pkgrel=8
pkgdesc="WebSocket client and server library for Python 2 and 3 as well as PyPy"
options="!check" # Tests are python2 only
url="https://github.com/Lawouach/WebSocket-for-Python"
arch="noarch"
license="BSD-3-Clause"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -21,7 +22,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="e3202d7bc547a5447eaeeeabe2ff18bd884c89c02cf54e27d88ca9cd14bcd9f080f7ff7e02d36538200c096df0442809c171c99e37b16ff818866c45b40eeef9 ws4py-0.5.1.tar.gz"