aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-xlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-xlib/APKBUILD')
-rw-r--r--community/py3-xlib/APKBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/community/py3-xlib/APKBUILD b/community/py3-xlib/APKBUILD
index f1bc1c2037a..3a81eb93206 100644
--- a/community/py3-xlib/APKBUILD
+++ b/community/py3-xlib/APKBUILD
@@ -1,40 +1,41 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
-# Maintainer: Ivan Tham <pickfire@riseup.net>
+# Maintainer:
pkgname=py3-xlib
_pkgname=python-xlib
-pkgver=0.31
-pkgrel=0
+pkgver=0.33
+pkgrel=3
pkgdesc="fully functional X client library for Python programs"
url="https://github.com/python-xlib/python-xlib"
arch="noarch"
license="LGPL-2.1-or-later"
depends="py3-six"
-checkdepends="xauth xvfb py3-mock py3-nose"
-makedepends="py3-setuptools"
-source="https://github.com/$_pkgname/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.bz2"
+makedepends="py3-gpep517 py3-setuptools_scm py3-wheel"
+checkdepends="py3-mock py3-pytest xvfb-run"
+subpackages="$pkgname-pyc"
+source="https://github.com/python-xlib/python-xlib/releases/download/$pkgver/python-xlib-$pkgver.tar.bz2"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-xlib" # Backwards compatibility
provides="py-xlib=$pkgver-r$pkgrel" # Backwards compatibility
-prepare() {
- default_prepare
-
- sed -e "s/setup_requires.*/version='$pkgver',/" -i setup.py
-}
-
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 ./runtests.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ xvfb-run -a .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-f98978cd0058ae18f08f9da71b4ff31cd7811040ec1eb03ce065c187f312259d674dd76aad447752c8f508e585838948c90182eef5d5240e6c06b0a5dd1fbd33 python-xlib-0.31.tar.bz2
+3b7b4fea5cd69544d2227806853bdfdd04447089e182ca0f199e18e8bd43375d9bf03c819fd6a055ad4ad274594651e05db82585ab40d0fcf225ce36b553c991 python-xlib-0.33.tar.bz2
"