aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-xxxswf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-xxxswf/APKBUILD')
-rw-r--r--community/py3-xxxswf/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py3-xxxswf/APKBUILD b/community/py3-xxxswf/APKBUILD
new file mode 100644
index 00000000000..92be356ad91
--- /dev/null
+++ b/community/py3-xxxswf/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-xxxswf
+pkgver=2.0.0
+pkgrel=4
+pkgdesc="script for carving, scanning, compressing, decompressing and analyzing Flash SWF files"
+url="https://bitbucket.org/Alexander_Hanel/xxxswf/src/master/"
+arch="noarch"
+license="GPL-3.0-or-later"
+options="!check" # no testsuite in pypi archive
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/x/xxxswf/xxxswf-$pkgver.tar.gz"
+builddir="$srcdir/xxxswf-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+5c324fc0d1e22c522f8ea60389faa749d43bbf79a2c096984470892093ba72cb84f20b2b0f84454bd953b558bcce33542ec674c9b1ff52c72b511d76fe993295 xxxswf-2.0.0.tar.gz
+"