aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-zipstream/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-zipstream/APKBUILD')
-rw-r--r--community/py3-zipstream/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/py3-zipstream/APKBUILD b/community/py3-zipstream/APKBUILD
index 08195522afd..dacc1d67670 100644
--- a/community/py3-zipstream/APKBUILD
+++ b/community/py3-zipstream/APKBUILD
@@ -3,30 +3,31 @@
pkgname=py3-zipstream
_pkgname=python-zipstream
pkgver=1.1.4
-pkgrel=5
+pkgrel=9
pkgdesc="Like Python's ZipFile module, except it works as a generator that provides the file in many small chunks."
url="https://github.com/allanlei/python-zipstream"
arch="noarch"
license="GPL-3.0-only"
depends="python3"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/allanlei/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-zipstream" # Backwards compatibility
provides="py-zipstream=$pkgver-r$pkgrel" # Backwards compatibility
-check() {
- python3 setup.py check
-}
-
-
build() {
python3 setup.py build
}
+check() {
+ pytest
+}
+
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="722c1d7db91dc47064fc51f1182417f46923b8f42a56e854f1fa125eaccfc7f86d3deab71709226a798a1caf5a84a8a7fa7d3564065ab91afbad434ed787ce32 py3-zipstream-1.1.4.tar.gz"