aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-zope-deprecation/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-zope-deprecation/APKBUILD')
-rw-r--r--community/py3-zope-deprecation/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/community/py3-zope-deprecation/APKBUILD b/community/py3-zope-deprecation/APKBUILD
index 476a5fec402..db24396cb6a 100644
--- a/community/py3-zope-deprecation/APKBUILD
+++ b/community/py3-zope-deprecation/APKBUILD
@@ -1,31 +1,41 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-zope-deprecation
-_pkgname=zope.deprecation
-pkgver=4.4.0
+pkgver=5.0
pkgrel=2
pkgdesc="Zope Deprecation Infrastructure"
url="https://github.com/zopefoundation/zope.deprecation"
arch="noarch"
license="ZPL-2.1"
depends="py3-setuptools"
-# checkdepends="py3-zope-testrunner" # Is in upper repo
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="py3-zope-testrunner"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/zope.deprecation/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir"/zope.deprecation-$pkgver
+options="!check" # todo import failure
replaces="py-zope-deprecation" # Backwards compatibility
provides="py-zope-deprecation=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ zope-testrunner --test-path=src
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="62371dc45fad6715f24cdcac1d25b559ed5248da774b5ecd215fb4d0b6fc0ab655bfb9e0fbceda964e8ffb7d70536e43f8fcf09d9f2742904717a6473869fa4a zope.deprecation-4.4.0.tar.gz"
+sha512sums="
+c194d5c5bf7a47311f7c85b21ecd9f2f238cb332859ca8fa4d20b98ae4041867497e5384f4de10f03b7a4005810700ed61cd3c86c46dd638a3780500eea7dd6c py3-zope-deprecation-5.0.tar.gz
+"