aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3status/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3status/APKBUILD')
-rw-r--r--community/py3status/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py3status/APKBUILD b/community/py3status/APKBUILD
new file mode 100644
index 00000000000..27b7b8b7aab
--- /dev/null
+++ b/community/py3status/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Guy Godfroy <guy.godfroy@gugod.fr>
+# Maintainer: Guy Godfroy <guy.godfroy@gugod.fr>
+pkgname=py3status
+pkgver=3.57
+pkgrel=2
+pkgdesc="Extensible i3status wrapper written in python"
+url="https://ultrabug.github.io/py3status/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-wheel
+ py3-hatchling
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ultrabug/py3status/archive/refs/tags/$pkgver.tar.gz"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+
+ install -Dm644 docs/*.md README.md CHANGELOG \
+ -t "$pkgdir"/usr/share/doc/$pkgname/
+ install -Dm644 docs/dev-guide/* \
+ -t "$pkgdir"/usr/share/doc/$pkgname/dev-guide/
+ install -Dm644 docs/user-guide/* \
+ -t "$pkgdir"/usr/share/doc/$pkgname/user-guide/
+ install -Dm644 LICENSE \
+ -t "$pkgdir"/usr/share/licenses/$pkgname/
+}
+
+sha512sums="
+e91f78c3b081f4e98a91bc82d81088dfef0da7fe00ca3b1c90c5054aeda9f64e79c8c09e886e13ad514297cb0fc5cdf327e1b11f99f59f33a8a44ffb7ff469e0 py3status-3.57.tar.gz
+"