aboutsummaryrefslogtreecommitdiffstats
path: root/community/qbittorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qbittorrent/APKBUILD')
-rw-r--r--community/qbittorrent/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/community/qbittorrent/APKBUILD b/community/qbittorrent/APKBUILD
index f21696eb95f..0cb48e1907b 100644
--- a/community/qbittorrent/APKBUILD
+++ b/community/qbittorrent/APKBUILD
@@ -1,22 +1,22 @@
# Contributor: Jan Tatje <jan@jnt.io>
-# Contributor: Simon Zeni <simon@bl4ckb0ne.ca>
-# Maintainer: psykose <alice@ayaya.dev>
+# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
pkgname=qbittorrent
-pkgver=4.4.3
+pkgver=4.6.4
pkgrel=0
pkgdesc="qBittorrent client"
url="https://www.qbittorrent.org/"
-arch="all !s390x" # qt6-qttools
+arch="all"
license="GPL-2.0-or-later"
options="!check" # qBittorrent has no tests
makedepends="
boost-dev
cmake
libtorrent-rasterbar-dev
- ninja
+ openssl-dev>3
qt6-qtbase-dev
qt6-qtsvg-dev
qt6-qttools-dev
+ samurai
"
subpackages="
$pkgname-doc
@@ -35,19 +35,19 @@ builddir="$srcdir/qBittorrent-release-$pkgver"
# - CVE-2019-13640
build() {
+ export CFLAGS="$CFLAGS -DNDEBUG -O2 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -DNDEBUG -O2 -flto=auto"
+
cmake -B build-gui -G Ninja \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
- -DWEBUI=OFF \
-DSTACKTRACE=OFF \
-DQT6=ON
cmake --build build-gui
cmake -B build-nox -G Ninja \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DGUI=OFF \
-DSTACKTRACE=OFF \
-DQT6=ON
@@ -85,7 +85,7 @@ nox_openrc() {
}
sha512sums="
-e3de225f2a2cabc7de3d9a555ad83620465c229f7c2b382362e550f320b1ce620282927753a26c2f320675b96fb6f91bad9bd0533d7400eea14120594f9d1275 qbittorrent-4.4.3.tar.gz
+9baee0f72890d5fdea77d8e7289012512f8fab3f4742adf4fc8d628a36ea4264f98ce43b15084ec188a93824d20f1f85de810d04bb5e804ac16eb696fb615061 qbittorrent-4.6.4.tar.gz
e84943b4e53717d4c53dc0a454aae2c43390b90afbd7e9d48c50cb914ac9041152a197677343ec81c6881bceb55228a2519bca9fffc158a713305214d0570711 qbittorrent-nox.initd
5cc840181f8b9febdc99b28dca9fe3f6b27a36bad0b20266e46d6ff148dfc9c5d9e6cba552198cd3d1b8ac5c21e2881d7defd8f13fcc8a862b93f4c80c1d4b19 qbittorrent-nox.confd
"