aboutsummaryrefslogtreecommitdiffstats
path: root/community/qmlkonsole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qmlkonsole/APKBUILD')
-rw-r--r--community/qmlkonsole/APKBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/community/qmlkonsole/APKBUILD b/community/qmlkonsole/APKBUILD
index 6847fec71c2..a63643bb5f4 100644
--- a/community/qmlkonsole/APKBUILD
+++ b/community/qmlkonsole/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=qmlkonsole
-pkgver=21.07
+pkgver=24.02.2
pkgrel=0
pkgdesc="Terminal app for Plasma Mobile"
# armhf blocked by extra-cmake-modules
@@ -9,24 +12,30 @@ arch="all !armhf"
url="https://invent.kde.org/plasma-mobile/qmlkonsole"
license="GPL-3.0-or-later"
depends="
- qmltermwidget
- kirigami2
+ kirigami-addons
+ kirigami
"
makedepends="
extra-cmake-modules
ki18n-dev
- kirigami2-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtquickcontrols2-dev
- qt5-qtsvg-dev
+ kirigami-addons-dev
+ kirigami-dev
+ kpty-dev
+ qt6-qt5compat-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/plasma-mobile/$pkgver/qmlkonsole-$pkgver.tar.xz"
-options="!check" # No tests
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma-mobile/qmlkonsole.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/qmlkonsole-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -37,5 +46,5 @@ package() {
}
sha512sums="
-efbd0f481eb31e4b9287fb8c8e2cb134bb747ac3bd228414c546b5cef4e224fcad31b0772d5409a8cc875db9574b3eae93ef2ae65ff01fe22f085de8e28cce92 qmlkonsole-21.07.tar.xz
+3d2773f7309fa180587fc5856be14697dc506b2198ac597434580e407c686ec1bff8f1c1d1d4bfad0925fe1c62b9464ab6b1038301a09d68370ada4c22e689aa qmlkonsole-24.02.2.tar.xz
"