aboutsummaryrefslogtreecommitdiffstats
path: root/community/qqc2-desktop-style/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qqc2-desktop-style/APKBUILD')
-rw-r--r--community/qqc2-desktop-style/APKBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/community/qqc2-desktop-style/APKBUILD b/community/qqc2-desktop-style/APKBUILD
index 76197e2c248..f0227b7f9ad 100644
--- a/community/qqc2-desktop-style/APKBUILD
+++ b/community/qqc2-desktop-style/APKBUILD
@@ -1,48 +1,53 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=qqc2-desktop-style
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="A style for Qt Quick Controls 2 to make it follow your desktop theme"
-# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !mips64 !s390x !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-3.0-only AND (GPL-2.0-only OR GPL-3.0-only)"
depends="
- qt5-qtgraphicaleffects
- qt5-qtquickcontrols2
+ kirigami
+ sonnet
"
depends_dev="
kconfigwidgets-dev
kiconthemes-dev
- kirigami2-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtx11extras-dev
+ kirigami-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/qqc2-desktop-style-$pkgver.tar.xz"
+checkdepends="xvfb-run"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/qqc2-desktop-style.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/qqc2-desktop-style-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ # TextFieldContextMenuTest requires working OpenGL
+ xvfb-run ctest --test-dir build --output-on-failure -E "animationspeedmodifiertest|TextFieldContextMenuTest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-9cb24d5013dea87fe96c4de464e8c72934e578385fe371880b6e599e46b45631c677f8b98c367bc60252cfadff2142da0652010d734c4f57d7ac46599bcb029a qqc2-desktop-style-5.84.0.tar.xz
+befb9c9ee024fcf73a04be9495800172d2049f9a0c14d21fe8e5c7d889a1411702de2297e1a27ca11154f7471b541ab1b02b182d38622a81eabd6b3a8aca1530 qqc2-desktop-style-6.1.0.tar.xz
"