aboutsummaryrefslogtreecommitdiffstats
path: root/community/qscintilla/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qscintilla/APKBUILD')
-rw-r--r--community/qscintilla/APKBUILD53
1 files changed, 32 insertions, 21 deletions
diff --git a/community/qscintilla/APKBUILD b/community/qscintilla/APKBUILD
index 1c5c954c93b..51ebaf9ba7d 100644
--- a/community/qscintilla/APKBUILD
+++ b/community/qscintilla/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Marian Buschsiewke <marian.buschsieweke@ovgu.de>
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=qscintilla
-pkgver=2.13.1
-pkgrel=0
+pkgver=2.14.1
+pkgrel=1
pkgdesc="QScintilla is a port to Qt of Neil Hodgson's Scintilla C++ editor control"
url="https://www.riverbankcomputing.com/software/qscintilla"
arch="all"
@@ -10,40 +10,41 @@ license="GPL-3.0-only"
subpackages="
$pkgname-designer:designer
$pkgname-dev
+ $pkgname-lang::noarch
"
makedepends="
- qt5-qtbase-dev
- qt5-qttools-dev
- py3-pyqt-builder
py3-ply
+ py3-pyqt-builder
py3-sip
python3-dev
+ qt5-qtbase-dev
+ qt5-qttools-dev
"
source="https://www.riverbankcomputing.com/static/Downloads/QScintilla/$pkgver/QScintilla_src-$pkgver.tar.gz"
builddir="$srcdir/QScintilla_src-$pkgver"
# py3-qscintilla is blocked by py3-qt5 on armhf
-_with_python3_bindings="yes"
+_with_python3_bindings="no"
case "$CARCH" in
armhf) ;;
*)
makedepends="$makedepends py3-qt5"
subpackages="$subpackages py3-$pkgname:py3"
- _with_python3_bindings="no"
+ _with_python3_bindings="yes"
;;
esac
build() {
- cd $builddir/src
+ cd "$builddir"/src
qmake-qt5
make
- cd $builddir/designer
+ cd "$builddir"/designer
qmake-qt5 INCLUDEPATH+=../src QMAKE_LIBDIR+=../src
make
- if [ "$_with_python3_bindings" != "yes" ]; then
- cd $builddir/Python
+ if [ "$_with_python3_bindings" = "yes" ]; then
+ cd "$builddir"/Python
mv pyproject-qt5.toml pyproject.toml
sip-build \
--no-make \
@@ -51,37 +52,47 @@ build() {
--qsci-features-dir ../src/features \
--qsci-include-dir ../src \
--qsci-library-dir ../src \
- --api-dir /usr/share/qt/qsci/api/python
+ --api-dir /usr/share/qt5/qsci/api/python
cd build
make
fi
}
check() {
- cd $builddir/src
+ cd src
make check
}
package() {
- cd $builddir/src
- make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+ make -C src DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+ make -C designer DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+
+ if [ "$_with_python3_bindings" = "yes" ]; then
+ make -C Python/build DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+ fi
}
designer() {
pkgdesc="$pkgname (Qt5 designer plugin)"
- depends="qscintilla"
+ depends="$pkgname=$pkgver-r$pkgrel"
- cd $builddir/designer
- make DESTDIR="$subpkgdir" INSTALL_ROOT="$subpkgdir" install
+ amove usr/lib/qt5/plugins/designer
}
py3() {
pkgdesc="$pkgname (Python3 bindings)"
depends="py3-qt5"
- cd $builddir/Python/build
- make DESTDIR="$subpkgdir" INSTALL_ROOT="$subpkgdir" install
+ amove usr/lib/python3*
+ amove usr/share/qt5/qsci/api/python/QScintilla.api
+}
+
+lang() {
+ install_if="lang $pkgname=$pkgver-r$pkgrel"
+
+ amove usr/share/qt5/translations
}
+
sha512sums="
-edf7f358e188235d8a39a7d4a8332ca478460a65a8829d9cafcab8f22b84abcd8d624de2076d81a66a56d5a5c53edc6ecc223459bbbb8ac876c5befd8873f700 QScintilla_src-2.13.1.tar.gz
+19e2f9e0a14947501c575018df368d24eb7f8c74e74faa5246db36415bf28dc0beee507ed0e73107c02b36a99bbaf55f0ef3349f479d2332e1b92b2c4a32788a QScintilla_src-2.14.1.tar.gz
"