aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtlocation/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt5-qtlocation/APKBUILD')
-rw-r--r--community/qt5-qtlocation/APKBUILD69
1 files changed, 42 insertions, 27 deletions
diff --git a/community/qt5-qtlocation/APKBUILD b/community/qt5-qtlocation/APKBUILD
index e5660f29104..d330965232b 100644
--- a/community/qt5-qtlocation/APKBUILD
+++ b/community/qt5-qtlocation/APKBUILD
@@ -1,45 +1,60 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtlocation
-_pkgname=${pkgname/qt5-//}-everywhere-src
-pkgver=5.12.5
-_ver=${pkgver/_/-}
-_ver=${_ver/beta0/beta}
-_ver=${_ver/rc0/rc}
-_V=${_ver/rc/RC}
-pkgrel=0
+pkgver=5.15.10_git20230612
+pkgrel=2
+_module="${pkgname#qt5-}"
+_pkgver=664701dc3acfca37500bc84ba03eed4953b684e9
+_fullname=$_module-$_pkgver
pkgdesc="Qt5 - Location component"
-url="http://qt-project.org/"
+url="https://www.qt.io/developers/"
+license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
arch="all"
-license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
-options="!check" # upstream does not provide check
-makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev icu-dev"
+makedepends="
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ icu-dev
+ "
subpackages="$pkgname-dev"
+options="!check" # No tests
+source="https://dev.alpinelinux.org/archive/qt/$_fullname.tar.xz"
+builddir="$srcdir/$_fullname"
-case $pkgver in
-*_beta*|*_rc*) _rel=development_releases;;
-*) _rel=official_releases;;
-esac
-source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz
- fix-build.patch"
-
-builddir="$srcdir"/$_pkgname-${_V%-*}
+_disturl="dev.alpinelinux.org:/archive/qt/"
+snapshot() {
+ clean
+ makedepends="git xz rsync tar" deps
+ mkdir -p "$srcdir" && cd "$srcdir"
+ git clone --filter=tree:0 https://invent.kde.org/qt/qt/$_module.git .
+ git archive --format tar --prefix=$_fullname/ $_pkgver > "$SRCDEST"/$_fullname.tar
+ xz -vv -T0 -9 -e "$SRCDEST"/$_fullname.tar
+ rsync --progress -La "$SRCDEST"/$_fullname.tar.xz $_disturl
+}
prepare() {
default_prepare
- cd "$builddir"
- mkdir -p build
+
+ # We need to make the build system think we're running in a git repository
+ # so it correctly symlinks during the build
+ mkdir .git
}
build() {
- cd "$builddir"/build
- qmake-qt5 "CONFIG+=posix" ..
+ qmake-qt5 "CONFIG+=posix"
make
}
package() {
- cd "$builddir"/build
make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="fe82194e4e6bc2a2e6e3c55e3360afdfd56a6495a8d87bfbdceb29255430954d4c1adc62f1f82e63b23778f0bf03b0a50d6f5d2a963bd786f2cf2fbed7450ccc qtlocation-everywhere-src-5.12.5.tar.xz
-eb19b97909b64a82d75732872573b25c626c924aec93dbbe9b1b27fd72354149aa0c4e2d3727a5a2519a7bee39cb6af60761ad40e29b4e7adeb89a300a710505 fix-build.patch"
+
+sha512sums="
+c5dc0ffbed5b7c97873e7b0a0cfb7bab96292814f0aa4ba9787d6f126586719d8efc424e1b151af717f62bfa6365e1450feb4325b9a992bd609e475b298d8405 qtlocation-664701dc3acfca37500bc84ba03eed4953b684e9.tar.xz
+"