aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtlocation/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt5-qtlocation/APKBUILD')
-rw-r--r--community/qt5-qtlocation/APKBUILD58
1 files changed, 32 insertions, 26 deletions
diff --git a/community/qt5-qtlocation/APKBUILD b/community/qt5-qtlocation/APKBUILD
index 18b943aa675..d330965232b 100644
--- a/community/qt5-qtlocation/APKBUILD
+++ b/community/qt5-qtlocation/APKBUILD
@@ -1,38 +1,42 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtlocation
-pkgver=5.15.3_git20201109
-pkgrel=0
-_commit="861e372b6ad81570d4f496e42fb25a6699b72f2f"
+pkgver=5.15.10_git20230612
+pkgrel=2
+_module="${pkgname#qt5-}"
+_pkgver=664701dc3acfca37500bc84ba03eed4953b684e9
+_fullname=$_module-$_pkgver
pkgdesc="Qt5 - Location component"
url="https://www.qt.io/developers/"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
-makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev icu-dev"
+arch="all"
+makedepends="
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ icu-dev
+ "
subpackages="$pkgname-dev"
options="!check" # No tests
-builddir="$srcdir/qtlocation"
-
-case $pkgver in
- *_beta*|*_rc*) _rel=development_releases;;
- *) _rel=official_releases;;
-esac
-
-source="https://dev.alpinelinux.org/archive/qt5-qtlocation/qtlocation-$_commit.tar.gz
- fix-build.patch
- "
-
-disturl="dev.alpinelinux.org:/archive/$pkgname/"
+source="https://dev.alpinelinux.org/archive/qt/$_fullname.tar.xz"
+builddir="$srcdir/$_fullname"
+_disturl="dev.alpinelinux.org:/archive/qt/"
snapshot() {
clean
- deps
- mkdir -p "$srcdir"
- cd "$srcdir"
- git clone https://invent.kde.org/qt/qt/qtlocation -b kde/5.15 --recursive
- cd qtlocation && git checkout $_commit && cd -
- tar czvf $SRCDEST/qtlocation-$_commit.tar.gz qtlocation
- rsync --progress -La $SRCDEST/qtlocation-$_commit.tar.gz $disturl
+ makedepends="git xz rsync tar" deps
+ mkdir -p "$srcdir" && cd "$srcdir"
+ git clone --filter=tree:0 https://invent.kde.org/qt/qt/$_module.git .
+ git archive --format tar --prefix=$_fullname/ $_pkgver > "$SRCDEST"/$_fullname.tar
+ xz -vv -T0 -9 -e "$SRCDEST"/$_fullname.tar
+ rsync --progress -La "$SRCDEST"/$_fullname.tar.xz $_disturl
+}
+
+prepare() {
+ default_prepare
+
+ # We need to make the build system think we're running in a git repository
+ # so it correctly symlinks during the build
+ mkdir .git
}
build() {
@@ -50,5 +54,7 @@ package() {
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="5e9feabbac29052377d2cd1ec22fa29b00de361122580f0f33128fadf12b72af711f2e1e114a3e82c7c00812b304287212d617c85fe1b5bb0f39f120c884d8cc qtlocation-861e372b6ad81570d4f496e42fb25a6699b72f2f.tar.gz
-eb19b97909b64a82d75732872573b25c626c924aec93dbbe9b1b27fd72354149aa0c4e2d3727a5a2519a7bee39cb6af60761ad40e29b4e7adeb89a300a710505 fix-build.patch"
+
+sha512sums="
+c5dc0ffbed5b7c97873e7b0a0cfb7bab96292814f0aa4ba9787d6f126586719d8efc424e1b151af717f62bfa6365e1450feb4325b9a992bd609e475b298d8405 qtlocation-664701dc3acfca37500bc84ba03eed4953b684e9.tar.xz
+"