aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtlocation/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt5-qtlocation/APKBUILD')
-rw-r--r--community/qt5-qtlocation/APKBUILD45
1 files changed, 23 insertions, 22 deletions
diff --git a/community/qt5-qtlocation/APKBUILD b/community/qt5-qtlocation/APKBUILD
index 8911e1daacd..d330965232b 100644
--- a/community/qt5-qtlocation/APKBUILD
+++ b/community/qt5-qtlocation/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtlocation
-pkgver=5.15.4_git20220511
-pkgrel=0
-_commit="db3b6bc6afed6477e6ab2d8465e41efee30fb6d5"
-_commit_mapbox="d3101bbc22edd41c9036ea487d4a71eabd97823d"
+pkgver=5.15.10_git20230612
+pkgrel=2
+_module="${pkgname#qt5-}"
+_pkgver=664701dc3acfca37500bc84ba03eed4953b684e9
+_fullname=$_module-$_pkgver
pkgdesc="Qt5 - Location component"
url="https://www.qt.io/developers/"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all"
makedepends="
qt5-qtbase-dev
qt5-qtdeclarative-dev
@@ -16,25 +17,25 @@ makedepends="
"
subpackages="$pkgname-dev"
options="!check" # No tests
-builddir="$srcdir/qtlocation-$_commit"
-
-case $pkgver in
- *_beta*|*_rc*) _rel=development_releases;;
- *) _rel=official_releases;;
-esac
-
-source="https://invent.kde.org/qt/qt/qtlocation/-/archive/$_commit/qtlocation-$_commit.tar.gz
- https://invent.kde.org/qt/qt/qtlocation-mapboxgl/-/archive/$_commit_mapbox/qtlocation-mapbox-$_commit_mapbox.tar.gz
- "
+source="https://dev.alpinelinux.org/archive/qt/$_fullname.tar.xz"
+builddir="$srcdir/$_fullname"
+
+_disturl="dev.alpinelinux.org:/archive/qt/"
+snapshot() {
+ clean
+ makedepends="git xz rsync tar" deps
+ mkdir -p "$srcdir" && cd "$srcdir"
+ git clone --filter=tree:0 https://invent.kde.org/qt/qt/$_module.git .
+ git archive --format tar --prefix=$_fullname/ $_pkgver > "$SRCDEST"/$_fullname.tar
+ xz -vv -T0 -9 -e "$SRCDEST"/$_fullname.tar
+ rsync --progress -La "$SRCDEST"/$_fullname.tar.xz $_disturl
+}
prepare() {
default_prepare
- rmdir src/3rdparty/mapbox-gl-native
- mv "$srcdir/qtlocation-mapboxgl-$_commit_mapbox" src/3rdparty/mapbox-gl-native
-
- # We need to make the build system think we're running in a git repository
- # so it correctly symlinks during the build
+ # We need to make the build system think we're running in a git repository
+ # so it correctly symlinks during the build
mkdir .git
}
@@ -53,7 +54,7 @@ package() {
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
+
sha512sums="
-36a4133edcb9f2cdeb75603c966aba3e5b9b6e071f00b24ab8920257471246fbe0c9cb73b41b4b2c6716a1d60d7bd12423694fdef53139b7f1e033fb677a8f60 qtlocation-db3b6bc6afed6477e6ab2d8465e41efee30fb6d5.tar.gz
-6e38e5ca0b9e17de690af79f4702278bdc933a74561aa135b3e82245df7d795602403048bcc5bce00237f774ce3957540a8bded1a71f8730a08da05dec1f039f qtlocation-mapbox-d3101bbc22edd41c9036ea487d4a71eabd97823d.tar.gz
+c5dc0ffbed5b7c97873e7b0a0cfb7bab96292814f0aa4ba9787d6f126586719d8efc424e1b151af717f62bfa6365e1450feb4325b9a992bd609e475b298d8405 qtlocation-664701dc3acfca37500bc84ba03eed4953b684e9.tar.xz
"