aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtremoteobjects/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt5-qtremoteobjects/APKBUILD')
-rw-r--r--community/qt5-qtremoteobjects/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/qt5-qtremoteobjects/APKBUILD b/community/qt5-qtremoteobjects/APKBUILD
new file mode 100644
index 00000000000..b1a16c82799
--- /dev/null
+++ b/community/qt5-qtremoteobjects/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=qt5-qtremoteobjects
+_pkgname=${pkgname/qt5-//}-everywhere-src
+pkgver=5.10.1
+_ver=${pkgver/_/-}
+_ver=${_ver/beta0/beta}
+_ver=${_ver/rc0/rc}
+_V=${_ver/rc/RC}
+pkgrel=0
+pkgdesc="Qt Remote Objects (QtRO) is an inter-process communication (IPC) module developed for Qt"
+url="http://qt-project.org/"
+arch="all"
+license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
+options="!check" #upstream does not provide check
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz"
+
+builddir="$srcdir"/$_pkgname-${_V%-*}
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ mkdir -p build
+}
+
+build() {
+ cd "$builddir"/build
+ qmake-qt5 ..
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"/build
+ make INSTALL_ROOT="$pkgdir" install
+}
+sha512sums="f7cee2a030edac8e6bc2846d77068bc5679d23278ef6c0af0a2f80665d34fdcc7ccd1cd5623116e430b8060acbbcfcd6597cb9aef82afe8d4fea7efeda2b3789 qtremoteobjects-everywhere-src-5.10.1.tar.xz"