aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtscript/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/qt5-qtscript/APKBUILD')
-rw-r--r--community/qt5-qtscript/APKBUILD65
1 files changed, 43 insertions, 22 deletions
diff --git a/community/qt5-qtscript/APKBUILD b/community/qt5-qtscript/APKBUILD
index 04696f0f63e..2c23b2e16c1 100644
--- a/community/qt5-qtscript/APKBUILD
+++ b/community/qt5-qtscript/APKBUILD
@@ -1,45 +1,66 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtscript
-_pkgname=${pkgname/qt5-//}-everywhere-src
-pkgver=5.12.5
-_ver=${pkgver/_/-}
-_ver=${_ver/beta0/beta}
-_ver=${_ver/rc0/rc}
-_V=${_ver/rc/RC}
+pkgver=5.15.10_git20230323
pkgrel=0
+_module="${pkgname#qt5-}"
+_pkgver=4f8c35a528586541ea55bb8b3361eaa6749e52b1
+_fullname=$_module-$_pkgver
pkgdesc="Qt5 - QtScript component"
-url="http://qt-project.org/"
+url="https://www.qt.io/developers/"
arch="all"
-license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
+license="( LGPL-2.0-or-later OR GPL-3.0-only OR GPL-2.0-or-later ) AND Qt-GPL-exception-1.0"
makedepends="qt5-qtbase-dev linux-headers"
subpackages="$pkgname-dev"
-
-case $pkgver in
-*_beta*|*_rc*) _rel=development_releases;;
-*) _rel=official_releases;;
-esac
-source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz
+source="https://dev.alpinelinux.org/archive/qt/$_fullname.tar.xz
qtscript-everywhere-src-5.10.1-sgidefs.patch
qtscript-s390x.patch
+ qtscript-loongarch64.patch
"
+builddir="$srcdir/$_fullname"
+
+_disturl="dev.alpinelinux.org:/archive/qt/"
+snapshot() {
+ clean
+ makedepends="git xz rsync tar" deps
+ mkdir -p "$srcdir" && cd "$srcdir"
+ git clone --filter=tree:0 https://invent.kde.org/qt/qt/$_module.git .
+ git archive --format tar --prefix=$_fullname/ $_pkgver > "$SRCDEST"/$_fullname.tar
+ xz -vv -T0 -9 -e "$SRCDEST"/$_fullname.tar
+ rsync --progress -La "$SRCDEST"/$_fullname.tar.xz $_disturl
+}
-builddir="$srcdir"/$_pkgname-${_V%-*}
+prepare() {
+ default_prepare
+
+ # We need to make the build system think we're running in a git repository
+ # so it correctly symlinks during the build
+ mkdir .git
+}
build() {
- cd "$builddir"
- qmake-qt5 && make
+ qmake-qt5
+ make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="a422e47873ddf4c84adf00f51b721465acedfac535b0daeede63eac0d41c6f4f07d5a5f86513c86e981f3a0024020be03730670befab2a20cd4d6564c98d6c90 qtscript-everywhere-src-5.12.5.tar.xz
+sha512sums="
+d43cba0e036b34fec59378660050444048c2c15025c2a74be35ef5867047e8b201233a5d3b90db3c1cf29eb1adb733a7f062631257ab73bce6f4abf200a6808d qtscript-4f8c35a528586541ea55bb8b3361eaa6749e52b1.tar.xz
c89124fc940ceaa5cfc52c8f48b8eef17bba575a080fad3f27d61e3da98ab5cfd4bb6ffaae09ccae81f6f7644719fa28d38d4b7a7fe4cdb4268673c39627eb22 qtscript-everywhere-src-5.10.1-sgidefs.patch
-a0a22824954d35495d9d08c2b82d6eeeec26765760d417b8bc72c51e1753d4bb9f5e55d5289001d2d6071669a0bfd4f856fc3d0cf58b509bcbcd5211df35e482 qtscript-s390x.patch"
+a0a22824954d35495d9d08c2b82d6eeeec26765760d417b8bc72c51e1753d4bb9f5e55d5289001d2d6071669a0bfd4f856fc3d0cf58b509bcbcd5211df35e482 qtscript-s390x.patch
+f2708815aec1c12b3d4cdaa93473504ab1139ccd3caf9c9fbda8113480e4394048d0024914c45ce51c6c627b03d12ae73be700bafa802a4c55cfb2e3b214846d qtscript-loongarch64.patch
+"